
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.ithaca.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="finger lakes, fllt, cayuga lake, ecology, hydrography, economics, biology, land trust, bell station project, nyseg, habitat" />
<meta name="news_keywords" content="finger lakes, fllt, cayuga lake, ecology, hydrography, economics, biology, land trust, bell station project, nyseg, habitat" />
<meta name="description" content="The Finger Lakes Land Trust (FLLT) today announced it has purchased the 480-acre Bell Station property, featuring 3,400 feet of pristine Cayuga Lake shoreline, from New York State Electric &amp;amp;" />
<meta name="author" content="Staff Report" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="w0ynWhI6f9U4DsYo5BcAL_Jcl8yem2CwsYhjuH71-eU" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1662%2C873%2C0%2C187&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Land Trust completes acquisition of Bell Station property" />
<meta property="og:description" content="The Finger Lakes Land Trust (FLLT) today announced it has purchased the 480-acre Bell Station property, featuring 3,400 feet of pristine Cayuga Lake shoreline, from New York State Electric &amp;amp;" />
<meta property="og:site_name" content="Ithaca Times " />
<meta property="og:section" content="Lansing" />
<meta property="fb:app_id" content="197614650372133" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Ithaca-Times/216472407397" />
<meta name="twitter:image" content="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1662%2C873%2C0%2C187&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ithacatimes" />
<meta name="twitter:image:alt" content="Senator Pam Helming &ndash; seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction &ndash; congratulated the land trust on acquiring the property on May 24." />
<meta property="tncms:ads" content="lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.496f084a596de555cc076783bc05ddcb.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0108c185ef3be15eaa06171a72c7f0cb.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/live/global/resources/styles/site.css?_dc=1453329769"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato:400,600,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT+Sans:400,600,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT+Serif:400,600,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto+Condensed:400,600,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.59905c960650c756bd917d9e081675c9.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.6"},"crm":{"group_id":"168"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/news\/lansing","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"Staff Report","start_hour":"05","id":"73852778-dc33-11ec-b340-eb77090dbea5","app":"editorial","ga_page":"\/news\/lansing\/article_73852778-dc33-11ec-b340-eb77090dbea5.html"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":309},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.6"},"crm":{"group_id":"168"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/news\/lansing","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"Staff Report","start_hour":"05","id":"73852778-dc33-11ec-b340-eb77090dbea5","app":"editorial","ga_page":"\/news\/lansing\/article_73852778-dc33-11ec-b340-eb77090dbea5.html"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":309},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-KWX6PNW');})();</script>
<script src="https://tags.crwdcntrl.net/c/13233/cc.js?ns=_cc13233" id="LOTCC_13233"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc13233.add('tp', 'TNNW');
		_cc13233.add('act', ' User Login');
		_cc13233.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc13233.add('med', 'flag: featured');
	_cc13233.bcp();
</script>

<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.f3739bd4d04bcee9e077d20b4f31f29c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://cdn.districtm.ca/merge/all.townNews.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = '73852778-dc33-11ec-b340-eb77090dbea5';
    __tnt.ads.dfp.targeting.k = ["finger lakes","fllt","cayuga lake","ecology","hydrography","economics","biology","land trust","bell station project","nyseg"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/ithaca.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[728,90], [970,90], [970,250]]).addSize([1200, 0], [[728,90], [970,90], [970,250]]).build();
                gptAdSlots['fixed-leaderboard-top'] = googletag.defineSlot(adUnit, [[728,90], [970,90], [970,250]], 'fixed-leaderboard-top').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-top'].setTargeting('pos', ['fixed-leaderboard-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], [728,90]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-leaderboard-top-tablet'] = googletag.defineSlot(adUnit, [728,90], 'fixed-leaderboard-top-tablet').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-top-tablet'].setTargeting('pos', ['fixed-leaderboard-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-leaderboard-top-mobile'] = googletag.defineSlot(adUnit, [320,50], 'fixed-leaderboard-top-mobile').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-top-mobile'].setTargeting('pos', ['fixed-leaderboard-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            
                gptAdSlots['ad-1656246'] = googletag.defineSlot(adUnit, [2,1], 'ad-1656246').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1656246'].setTargeting('pos', ['block-impact-top','atf']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"bg_color":"","border_width":"5","card_shadow":"enabled","card_shape":"rectangle","content_text":"Get the the latest local news, weather & arts coverage from the Ithaca Times.","content_text_color":"dark","content_text_shadow":"disabled","display_again":"24","display_timer":"3","display_triggers":"visitor_enter","email_button_style":"default","email_text_color":"dark","email_text_shadow":"disabled","enable_email":"1","heading_tag":"h3","headline_shadow":"disabled","headline_size":"large","headline_text":"Good morning Ithaca!","headline_text_color":"dark","hide_audience":"newslettersubscribers","image":{},"image_display":"full_width","info_text_color":"dark","info_text_shadow":"disabled","lead_in":"Ithaca Times Newsletter","lead_text_shadow":"disabled","list_ids":"7b030246-ffb8-11e8-9497-5b98eeea2753","manage_button_text":"Manage my subscriptions","outline_color":"#f00000","overlay_action":"centered","require_user_account":"","sign_up_text":"Subscribe","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_text_color":"dark","info_text":"","button_text":"","button_url":"","button_style":"default","button_size":" ","signup_lists_only":"","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","show_audience":"","block_id":"1923437"}); /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"","border_width":"5","card_shadow":"enabled","card_shape":"rectangle","content_text":"Get the the latest local news, weather & arts coverage from the Ithaca Times.","content_text_color":"dark","content_text_shadow":"disabled","display_again":"24","display_timer":"3","display_triggers":"visitor_enter","email_button_style":"default","email_text_color":"dark","email_text_shadow":"disabled","enable_email":"1","heading_tag":"h3","headline_shadow":"disabled","headline_size":"large","headline_text":"Good morning Ithaca!","headline_text_color":"dark","hide_audience":"newslettersubscribers","image":{},"image_display":"full_width","info_text_color":"dark","info_text_shadow":"disabled","lead_in":"Ithaca Times Newsletter","lead_text_shadow":"disabled","list_ids":"7b030246-ffb8-11e8-9497-5b98eeea2753","manage_button_text":"Manage my subscriptions","outline_color":"#f00000","overlay_action":"centered","require_user_account":"","sign_up_text":"Subscribe","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_text_color":"dark","info_text":"","button_text":"","button_url":"","button_style":"default","button_size":" ","signup_lists_only":"","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"utm_campaign_name","show_audience":"","block_id":"1923437"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            
                gptAdSlots['ad-1543102'] = googletag.defineSlot(adUnit, [300,250], 'ad-1543102').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543102'].setTargeting('pos', ['automatic-ad-asset','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#dee4ed","heading_tag":"h4","list_ids":"7b030246-ffb8-11e8-9497-5b98eeea2753","manage_button_text":"Manage subscriptions","sign_up_text":"Get the Ithaca Times Daily!","text_color":"dark","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","signup_lists_only":"","show_select_all":"","show_audience":"","hide_audience":"","block_id":"1814604"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250], [300,600]]).addSize([1200, 0], [[300,250], [300,600]]).build();
                gptAdSlots['fixed-big-ad-top'] = googletag.defineSlot(adUnit, [[300,250], [300,600]], 'fixed-big-ad-top').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top'].setTargeting('pos', ['fixed-big-ad-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            
                gptAdSlots['ad-1615347'] = googletag.defineSlot(adUnit, [300,250], 'ad-1615347').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1615347'].setTargeting('pos', ['block-big-ad-top','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300,250]).addSize([768, 0], [300,250]).addSize([992, 0], [[300,250],[300,600]]).addSize([1200, 0], [[300,250],[300,600]]).build();
                gptAdSlots['ad-1656243'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1656243').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1656243'].setTargeting('pos', ['block-big-ad-middle','stf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374","asset_id":"37319c08-dc50-11ec-b5e8-5f4ce33e50ad","title":"Have you gotten your first sunburn yet?","url":"\/opinion\/question_of_the_week\/have-you-gotten-your-first-sunburn-yet\/poll_37319c08-dc50-11ec-b5e8-5f4ce33e50ad.html","results":"https:\/\/www.ithaca.com\/opinion\/question_of_the_week\/have-you-gotten-your-first-sunburn-yet\/poll_37319c08-dc50-11ec-b5e8-5f4ce33e50ad.html?action=poll:results&format=json","chart":"pie"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300,250]).addSize([768, 0], [300,250]).addSize([992, 0], [[300,250],[300,600]]).addSize([1200, 0], [[300,250],[300,600]]).build();
                gptAdSlots['ad-1656244'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1656244').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1656244'].setTargeting('pos', ['block-big-ad-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            
                gptAdSlots['ad-1656248'] = googletag.defineSlot(adUnit, [300,250], 'ad-1656248').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1656248'].setTargeting('pos', ['block-rail-sticky','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"bg_color":"#dee4ed","heading_tag":"h4","links_position":"top","note":"","require_user_account":"","signup_lists_only":"1","sign_up_text":"Stay Tuned!","text_color":"dark","heading_bg_color":"","heading_text_color":"inherit","list_ids":"","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"1236470"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[728,90], [970,90], [970,250]]).addSize([1200, 0], [[728,90], [970,90], [970,250]]).build();
                gptAdSlots['fixed-leaderboard-bottom'] = googletag.defineSlot(adUnit, [[728,90], [970,90], [970,250]], 'fixed-leaderboard-bottom').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-bottom'].setTargeting('pos', ['fixed-leaderboard-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], []).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['fixed-leaderboard-bottom-mobile'] = googletag.defineSlot(adUnit, [320,50], 'fixed-leaderboard-bottom-mobile').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-leaderboard-bottom-mobile'].setTargeting('pos', ['fixed-leaderboard-bottom','btf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22676009902/ithaca.com/news/lansing';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [728,90]).addSize([992, 0], [728,90]).addSize([1200, 0], []).build();
                gptAdSlots['ad-1535479'] = googletag.defineSlot(adUnit, [[320,50],[728,90]], 'ad-1535479').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1535479'].setTargeting('pos', ['block-leaderboard-sticky-anchor','atf']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Land Trust completes acquisition of Bell Station property | Lansing | ithaca.com</title>
<link rel="apple-touch-icon" sizes="57x57" href="//ithaca.com/app/media/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="//ithaca.com/app/media/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="//ithaca.com/app/media/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="//ithaca.com/app/media/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="//ithaca.com/app/media/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="//ithaca.com/app/media/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="//ithaca.com/app/media/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="//ithaca.com/app/media/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="//ithaca.com/app/media/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="//ithaca.com/app/media/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="//ithaca.com/app/media/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="//ithaca.com/app/media/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="//ithaca.com/app/media/favicon-16x16.png">
<link rel="manifest" href="//ithaca.com/app/media/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="//ithaca.com/app/media/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.ithaca.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/9287de88-0ea8-11e9-8d50-5f47390e9d90.jpg?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//cdn.districtm.ca">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Land Trust completes acquisition of Bell Station property | Lansing | ithaca.com" href="http://www.ithaca.com/search/?f=rss&amp;t=article&amp;c=news/lansing&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.46a248d75dc687aa8d928092f6b77fc7.js"></script>
            <script>
$(function(){
  
  $("#site-search-1236401 .input-group-btn .btn").append('<i class="fas tnt-search" aria-hidden="true"></i>');
});

</script>

<!-- jsandy #63856 -->
<script type='text/javascript' src='http://partner.googleadservices.com/gampad/google_service.js'> </script>
<script type='text/javascript'> GS_googleAddAdSenseService("ca-pub-9611857892612150"); GS_googleEnableAllServices(); </script>
<script type='text/javascript'> GA_googleAddSlot("ca-pub-9611857892612150", "POA_160x600"); GA_googleAddSlot("ca-pub-9611857892612150", "POA_250x250"); GA_googleAddSlot("ca-pub-9611857892612150", "POA_300x250");GA_googleAddSlot("ca-pub-9611857892612150", "POA_300x60"); GA_googleAddSlot("ca-pub-9611857892612150", "POA_300x600"); GA_googleAddSlot("ca-pub-9611857892612150", "POA_728x90"); GA_googleAddSlot("ca-pub-9611857892612150", "POA_120x240"); </script>
<script type='text/javascript'> GA_googleFetchAds(); </script>


        </head>
        <body class="fixed-nav app-editorial grid-banded blox-asset uuid-73852778-dc33-11ec-b340-eb77090dbea5  section-news section-lansing type-article infinity-disabled" data-path="/news/lansing">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.ithaca.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.6&amp;townnews.crm.group_id=168&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=banded&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Flansing&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=true&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=Staff+Report&amp;tncms.asset.start_hour=05&amp;tncms.asset.id=73852778-dc33-11ec-b340-eb77090dbea5&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Flansing%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=dfp+premium&amp;tncms.system.render_time=309&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KWX6PNW&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.6&amp;townnews.crm.group_id=168&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=banded&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Flansing&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=true&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=Staff+Report&amp;tncms.asset.start_hour=05&amp;tncms.asset.id=73852778-dc33-11ec-b340-eb77090dbea5&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Flansing%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=dfp+premium&amp;tncms.system.render_time=309&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><div id="fb-root"></div>
        
        

        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.ithaca.com/tncms/admin/editorial-asset/?edit=73852778-dc33-11ec-b340-eb77090dbea5"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1236403" class="tncms-block hidden-md hidden-lg"><section id="block-1236403" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1236403" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1236403" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1236403" class="site-search-form input-group default normal form-control">
        <label for="site-search-1236403-term" class="sr-only">Site search</label>
        <input id="site-search-1236403-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1236403-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
                <span id="site-search-button-1236403" class="hidden-xs hidden-sm sr-only">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div><div id="tncms-block-1236418" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1236418" class="user-controls show-onload clearfix default"><div class="large-user-avatar pull-left">
            <div class="tn-user-avatar pull-left"><!-- user avatar --></div>
        </div>
        <div class="large-user-controls pull-left">
            <div class="user-welcome">Welcome, <span class="tn-user-screenname">Guest</span></div><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.ithaca.com/users/signup/?referer_url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html" class=" user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.ithaca.com/users/login/?referer_url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html" class=" user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.ithaca.com/users/admin/">Dashboard</a></li>
                    <li><a class="logout-btn" onclick="document.getElementById('user-logout-form-1236418').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><span class="user-control-link">My Account</span>
                    <b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.ithaca.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.ithaca.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.ithaca.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1236418').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

    </div>

<form method="post" action="https://www.ithaca.com/users/logout/" id="user-logout-form-1236418"><input type="hidden" name="referer_url" value="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home ">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news ">NEWS</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/ithaca/"  class="nav-link tnt-section-ithaca">Ithaca</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/tompkins_county/"  class="nav-link tnt-section-tompkins-county">Tompkins County</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/candor/"  class="nav-link tnt-section-candor">Candor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/dryden/"  class="nav-link tnt-section-dryden">Dryden</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/groton/"  class="nav-link tnt-section-groton">Groton</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/interlaken/"  class="nav-link tnt-section-interlaken">Interlaken</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/lansing/"  class="nav-link tnt-section-lansing">Lansing</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/newfield/"  class="nav-link tnt-section-newfield">Newfield</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/ovid/"  class="nav-link tnt-section-ovid">Ovid</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/south_seneca/"  class="nav-link tnt-section-south-seneca">South Seneca</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/spencer_van_etten/"  class="nav-link tnt-section-spencervan-etten">Spencer/Van Etten</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/trumansburg/"  class="nav-link tnt-section-trumansburg">Trumansburg</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/business/"  class="nav-link tnt-section-biztimes">BizTimes</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports ">SPORTS</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/steve_lawrence/"  class="nav-link tnt-section-steve-lawrence">Steve Lawrence</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/around_the_lake/"  class="nav-link tnt-section-around-the-lake">Around the Lake</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/calendar/"  class="nav-link tnt-section-events ">EVENTS</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/entertainment"  class="nav-link tnt-section-entertainment ">ENTERTAINMENT</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/entertainment/art/"  class="nav-link tnt-section-art">Art</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/entertainment/books/"  class="nav-link tnt-section-books">Books</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/entertainment/film/"  class="nav-link tnt-section-film">Film</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/entertainment/music/"  class="nav-link tnt-section-music">Music</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/entertainment/stage/"  class="nav-link tnt-section-stage">Stage</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/entertainment/weekend_planner/"  class="nav-link tnt-section-weekend-planner">Weekend Planner</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/flx/"  class="nav-link tnt-section-flx ">FLX</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/dining/"  class="nav-link tnt-section-dining">Dining </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/dining/"  class="nav-link tnt-section-dining ">DINING</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion ">OPINION</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_opinions/"  class="nav-link tnt-section-guest-opinions">Guest Opinions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_opinions/"  class="nav-link tnt-section-guest-opinions">Guest Opinions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_the_editor"  class="nav-link tnt-section-letters-to-the-editor">Letters To The Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/question_of_the_week/"  class="nav-link tnt-section-question_of_the_week">Question_of_the_week</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/columnists/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classifieds ">CLASSIFIEDS</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/vehicle"  class="nav-link tnt-section-automotive">Automotive</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/community"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/job"  class="nav-link tnt-section-employment">Employment</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/sale"  class="nav-link tnt-section-items-for-sale">Items for Sale</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing/rent/"  class="nav-link tnt-section-rentals">Rentals</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/housing"  class="nav-link tnt-section-real-estate-for-sale">Real Estate for Sale</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/service"  class="nav-link tnt-section-services">Services</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/back_page/"  class="nav-link tnt-section-back-page">Back Page</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/best_of_ithaca/"  class="nav-link tnt-section-best-of-ithaca ">BEST OF ITHACA</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/special_sections/"  class="nav-link tnt-section-special-sections ">SPECIAL SECTIONS</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li id="menu-advertise">
                <a href="/site/advertise.html" >
                    
                    Advertise
                </a></li><li id="menu-contactus">
                <a href="/site/contact_us.html" >
                    
                    Contact Us
                </a></li><li id="menu-newstip">
                <a href="/site/forms/news_tip" >
                    
                    News Tip
                </a></li><li id="menu-lettertotheeditor">
                <a href="/site/forms/letter_to_the_editor/" >
                    
                    Letter to the Editor
                </a></li><li id="menu-newsletters">
                <a href="/newsletters/" >
                    
                    Newsletters
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1236401" class="tncms-block"><section id="block-1236401" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1236401" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1236401" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1236401" class="site-search-form input-group pull-right input-group-sm form-control">
        <label for="site-search-1236401-term" class="sr-only">Site search</label>
        <input id="site-search-1236401-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1236401-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
                <span id="site-search-button-1236401" class="hidden-xs hidden-sm sr-only">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div></div></div>
    <div id="topbar-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-topbar-col-three" class="tncms-region "><div id="tncms-block-1236420" class="tncms-block pull-right"><div id="weather-1236420" class="weather-current size-small pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=14850" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">65&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="14850">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_1236420" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Ithaca, NY
                                
                                <small>(14850)</small>
                            </h4><h5>Today</h5>
                                <p>Considerable clouds this morning. Some decrease in clouds later in the day. High 79F. Winds S at 10 to 20 mph..
                                </p>
                                <h5>Tonight</h5>
                                <p>Cloudy. Slight chance of a rain shower. Low 66F. Winds S at 10 to 20 mph.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: May 26, 2022 @ 8:48 am</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=14850"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-1236417" class="tncms-block pull-right"><div id="user-controls-1236417" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.ithaca.com/users/signup/?referer_url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.ithaca.com/users/login/?referer_url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.ithaca.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1236417').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.ithaca.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.ithaca.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.ithaca.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1236417').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.ithaca.com/users/logout/" id="user-logout-form-1236417"><input type="hidden" name="referer_url" value="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div></div>
                </div>
            </header>
        </div>
    

    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default navbar-fixed-top">
                
                <div class="container">
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1236395" class="tncms-block site-logo"><section id="block-1236395" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  aria-label="Ithaca Times">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/c4f61c70-0bf1-11e6-89f0-ff4bdfe25d97.png?resize=150%2C94 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/c4f61c70-0bf1-11e6-89f0-ff4bdfe25d97.png?resize=200%2C125 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/c4f61c70-0bf1-11e6-89f0-ff4bdfe25d97.png?resize=225%2C140 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/c4f61c70-0bf1-11e6-89f0-ff4bdfe25d97.png?resize=300%2C187 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/c4f61c70-0bf1-11e6-89f0-ff4bdfe25d97.png?resize=400%2C249 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/c4f61c70-0bf1-11e6-89f0-ff4bdfe25d97.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="449"
                height="280"
                alt="Ithaca Times"
                ></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li id="menu-home">
                <a href="/" >
                    
                    
                        <span class="fas tnt-home"></span>
                    
                </a></li><li class="dropdown" id="menu-news">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news" >
                    
                    NEWS
                </a><ul id="main-nav_menu-child" class="dropdown-menu"><li id="menu-ithaca">
                <a href="/news/ithaca/" >
                    
                    Ithaca
                </a></li><li id="menu-tompkinscounty">
                <a href="/news/tompkins_county/" >
                    
                    Tompkins County
                </a></li><li id="menu-candor">
                <a href="/news/candor/" >
                    
                    Candor
                </a></li><li id="menu-dryden">
                <a href="/news/dryden/" >
                    
                    Dryden
                </a></li><li id="menu-groton">
                <a href="/news/groton/" >
                    
                    Groton
                </a></li><li id="menu-interlaken">
                <a href="/news/interlaken/" >
                    
                    Interlaken
                </a></li><li id="menu-lansing">
                <a href="/news/lansing/" >
                    
                    Lansing
                </a></li><li id="menu-newfield">
                <a href="/news/newfield/" >
                    
                    Newfield
                </a></li><li id="menu-ovid">
                <a href="/news/ovid/" >
                    
                    Ovid
                </a></li><li id="menu-southseneca">
                <a href="/news/south_seneca/" >
                    
                    South Seneca
                </a></li><li id="menu-spencer/vanetten">
                <a href="/news/spencer_van_etten/" >
                    
                    Spencer/Van Etten
                </a></li><li id="menu-trumansburg">
                <a href="/news/trumansburg/" >
                    
                    Trumansburg
                </a></li><li id="menu-biztimes">
                <a href="/news/business/" >
                    
                    BizTimes
                </a></li></ul></li><li class="dropdown" id="menu-sports">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports" >
                    
                    SPORTS
                </a><ul id="main-nav_menu-child" class="dropdown-menu"><li id="menu-stevelawrence">
                <a href="/sports/steve_lawrence/" >
                    
                    Steve Lawrence
                </a></li><li id="menu-aroundthelake">
                <a href="/sports/around_the_lake/" >
                    
                    Around the Lake
                </a></li></ul></li><li id="menu-events">
                <a href="/calendar/" >
                    
                    EVENTS
                </a></li><li class="dropdown" id="menu-entertainment">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/entertainment" >
                    
                    ENTERTAINMENT
                </a><ul id="main-nav_menu-child" class="dropdown-menu"><li id="menu-art">
                <a href="/entertainment/art/" >
                    
                    Art
                </a></li><li id="menu-books">
                <a href="/entertainment/books/" >
                    
                    Books
                </a></li><li id="menu-film">
                <a href="/entertainment/film/" >
                    
                    Film
                </a></li><li id="menu-music">
                <a href="/entertainment/music/" >
                    
                    Music
                </a></li><li id="menu-stage">
                <a href="/entertainment/stage/" >
                    
                    Stage
                </a></li><li id="menu-weekendplanner">
                <a href="/entertainment/weekend_planner/" >
                    
                    Weekend Planner
                </a></li></ul></li><li class="dropdown" id="menu-flx">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/flx/" >
                    
                    FLX
                </a><ul id="main-nav_menu-child" class="dropdown-menu"><li id="menu-dining">
                <a href="/dining/" >
                    
                    Dining 
                </a></li></ul></li><li id="menu-dining">
                <a href="/dining/" >
                    
                    DINING
                </a></li><li class="dropdown" id="menu-opinion">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/" >
                    
                    OPINION
                </a><ul id="main-nav_menu-child" class="dropdown-menu"><li id="menu-editorials">
                <a href="/opinion/editorials/" >
                    
                    Editorials
                </a></li><li id="menu-guestopinions">
                <a href="/opinion/guest_opinions/" >
                    
                    Guest Opinions
                </a></li><li id="menu-guestopinions">
                <a href="/opinion/guest_opinions/" >
                    
                    Guest Opinions
                </a></li><li id="menu-letterstotheeditor">
                <a href="/opinion/letters_to_the_editor" >
                    
                    Letters To The Editor
                </a></li><li id="menu-question_of_the_week">
                <a href="/opinion/question_of_the_week/" >
                    
                    Question_of_the_week
                </a></li><li class="dropdown" id="menu-columnists">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-nested="menu"   href="/opinion/columnists/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    
                    Columnists
                </a><ul id="main-nav_menu-child-child" class="dropdown-menu"><li id="menu-community_connections">
                <a href="/opinion/columnists/community_connections/" >
                    
                    Community_connections
                </a></li><li id="menu-ithaca_notes">
                <a href="/opinion/columnists/ithaca_notes/" >
                    
                    Ithaca_notes
                </a></li><li id="menu-surrounded_by_reality">
                <a href="/opinion/columnists/surrounded_by_reality/" >
                    
                    Surrounded_by_reality
                </a></li></ul></li></ul></li><li class="dropdown" id="menu-classifieds">
                <a class="dropdown-toggle" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds" >
                    
                    CLASSIFIEDS
                </a><ul id="main-nav_menu-child" class="dropdown-menu"><li id="menu-automotive">
                <a href="/classifieds/vehicle" >
                    
                    Automotive
                </a></li><li id="menu-community">
                <a href="/classifieds/community" >
                    
                    Community
                </a></li><li id="menu-employment">
                <a href="/classifieds/job" >
                    
                    Employment
                </a></li><li id="menu-itemsforsale">
                <a href="/classifieds/sale" >
                    
                    Items for Sale
                </a></li><li id="menu-rentals">
                <a href="/classifieds/housing/rent/" >
                    
                    Rentals
                </a></li><li id="menu-realestateforsale">
                <a href="/classifieds/housing" >
                    
                    Real Estate for Sale
                </a></li><li id="menu-services">
                <a href="/classifieds/service" >
                    
                    Services
                </a></li><li id="menu-backpage">
                <a href="/classifieds/back_page/" >
                    
                    Back Page
                </a></li></ul></li><li id="menu-bestofithaca">
                <a href="/best_of_ithaca/" >
                    
                    BEST OF ITHACA
                </a></li><li id="menu-specialsections">
                <a href="/special_sections/" >
                    
                    SPECIAL SECTIONS
                </a></li></ul></div>
                        </div>
                    </div>
                

                </div>
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
        <div id="top-container-breakout" class="container-breakout">
        <div class="visible-lg visible-md"><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-leaderboard-top" class="tnt-ads dfp-ad" style="min-height:90px; min-width:728px;" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-top');
                        googletag.pubads().refresh([gptAdSlots['fixed-leaderboard-top']]);
                });
            </script>
        </div>
    </div></div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-leaderboard-top-tablet" class="tnt-ads dfp-ad" style="min-height:90px; min-width:728px;" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-top-tablet');
                        googletag.pubads().refresh([gptAdSlots['fixed-leaderboard-top-tablet']]);
                });
            </script>
        </div>
    </div></div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg " >
        <div id="fixed-leaderboard-top-mobile" class="tnt-ads dfp-ad" style="min-height:50px; min-width:320px;" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-top-mobile');
                        googletag.pubads().refresh([gptAdSlots['fixed-leaderboard-top-mobile']]);
                });
            </script>
        </div>
    </div>
       </div>
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"><div id="tncms-block-1894431" class="tncms-block"><section id="block-1894431" class="block emphasis-h1   " ><div class="heading card">
    
    
        
        <ol class="breadcrumb  pull-right" itemscope itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/" itemprop="item">
                        <span itemprop="name">Home</span>
                    </a>
                    <meta itemprop="position" content="1" />
                </li><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/news/" itemprop="item">
                        <span itemprop="name">News</span>
                    </a>
                    <meta itemprop="position" content="2" />
                </li><li class="active" itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/news/lansing/" itemprop="item">
                        <span itemprop="name">Lansing</span>
                    </a>
                    <meta itemprop="position" content="3" />
                </li></ol>
    
    <div class="clearfix">
    
    <div class="block-title title-1894431 ">
        <div class="block-title-inner">
            <h1>
                
                    <a href="/news/lansing">
                
                Lansing
                
                    </a>
                
            </h1>
        </div>
    </div></div>
    
</div></section></div></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1656246" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1656246" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1656246');
                        googletag.pubads().refresh([gptAdSlots['ad-1656246']]);
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-bb88be36-dc33-11ec-8b1a-0f121256da2e" class="modal fullscreen in modal-image image-default modal-bb88be36-dc33-11ec-8b1a-0f121256da2e" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-white">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=400%2C300"
                        srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=150%2C113 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=200%2C150 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=225%2C169 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=300%2C225 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=400%2C300 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=540%2C405 540w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=640%2C480 640w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=750%2C563 750w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=990%2C743 990w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1035%2C777 1035w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1200%2C900 1200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1333%2C1000 1333w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1476%2C1107 1476w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1662%2C1247 2008w"
                        sizes="100vw"
                        
                        width="1662"
                        height="1247"
                        alt="Senator Pam Helming – seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction – congratulated the land trust on acquiring the property on May 24."
                        class="img-responsive true-size white" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-bb88be36-dc33-11ec-8b1a-0f121256da2e" data-target=".caption-inner-modal-image-bb88be36-dc33-11ec-8b1a-0f121256da2e">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-bb88be36-dc33-11ec-8b1a-0f121256da2e collapse in"><div class="caption-text"><p><em>Senator Pam Helming – seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction – congratulated the land trust on acquiring the property on May 24.</em></p><p><em> </em></p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">photo/Andrew Sullivan</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ithaca.com%2Fsenator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the%2Fimage_bb88be36-dc33-11ec-8b1a-0f121256da2e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/senator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the/image_bb88be36-dc33-11ec-8b1a-0f121256da2e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bb88be36-dc33-11ec-8b1a-0f121256da2e"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Senator%20Pam%20Helming%20%E2%80%93%20seen%20here%20meeting%20with%20Lansing%20constituents%20when%20the%20news%20came%20that%20the%20Bell%20Station%20property%20was%20put%20up%20for%20auction%20%E2%80%93%20congratulated%20the%20land%20trust%20on%20acquiring%20the%20property%20on%20May%2024.&via=ithacatimes&url=https%3A%2F%2Fwww.ithaca.com%2Fsenator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the%2Fimage_bb88be36-dc33-11ec-8b1a-0f121256da2e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/senator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the/image_bb88be36-dc33-11ec-8b1a-0f121256da2e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bb88be36-dc33-11ec-8b1a-0f121256da2e"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ithaca.com/senator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the/image_bb88be36-dc33-11ec-8b1a-0f121256da2e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/senator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the/image_bb88be36-dc33-11ec-8b1a-0f121256da2e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bb88be36-dc33-11ec-8b1a-0f121256da2e"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ithaca.com/tncms/asset/editorial/bb88be36-dc33-11ec-8b1a-0f121256da2e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"bb88be36-dc33-11ec-8b1a-0f121256da2e"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIthaca%20Times%20%5D%20Senator%20Pam%20Helming%20%E2%80%93%20seen%20here%20meeting%20with%20Lansing%20constituents%20when%20the%20news%20came%20that%20the%20Bell%20Station%20property%20was%20put%20up%20for%20auction%20%E2%80%93%20congratulated%20the%20land%20trust%20on%20acquiring%20the%20property%20on%20May%2024.&body=https%3A%2F%2Fwww.ithaca.com%2Fsenator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the%2Fimage_bb88be36-dc33-11ec-8b1a-0f121256da2e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"bb88be36-dc33-11ec-8b1a-0f121256da2e"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/senator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the/image_bb88be36-dc33-11ec-8b1a-0f121256da2e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bb88be36-dc33-11ec-8b1a-0f121256da2e"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-bb88be36-dc33-11ec-8b1a-0f121256da2e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="bb88be36-dc33-11ec-8b1a-0f121256da2e" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="bb88be36-dc33-11ec-8b1a-0f121256da2e" class="save-list-bb88be36-dc33-11ec-8b1a-0f121256da2e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="bb88be36-dc33-11ec-8b1a-0f121256da2e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-bb88be36-dc33-11ec-8b1a-0f121256da2e img { max-height: 825px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-73852778-dc33-11ec-b340-eb77090dbea5" class="asset article-default"  data-url="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="The Finger Lakes Land Trust (FLLT) today announced it has purchased the 480-acre Bell Station property, featuring 3,400 feet of pristine Cayuga Lake shoreline, from New York State Electric &amp; Gas (NYSEG). The property, located in the town of Lansing, Tompkins County, was the largest privately owned parcel of shoreline remaining in the Finger Lakes region. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1662%2C873%2C0%2C187&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="ithaca.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html" />
    <style>
                .asset-paging .direction {
                    color: #eda64c;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.ithaca.com\/tncms\/search\/mlt\/?origin=73852778-dc33-11ec-b340-eb77090dbea5&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"73852778-dc33-11ec-b340-eb77090dbea5","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-73852778-dc33-11ec-b340-eb77090dbea5" class="asset-paging">
                <div id="paging-prev-73852778-dc33-11ec-b340-eb77090dbea5" class="paging-link prev offset"></div>
                <div id="paging-next-73852778-dc33-11ec-b340-eb77090dbea5" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper has-flags">
        
            <div class="asset-label-flags has-work">
                <span class="tnt-flag label label-flag label-flag-default label-flag-featured">featured</span> 
            </div>
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Land Trust completes acquisition of Bell Station property
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">Staff Report</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-05-26T05:00:00-04:00" class="tnt-date asset-date text-muted">
            May 26, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-05-26T05:00:00-04:00" class="tnt-date asset-date text-muted">3 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count comment-counter">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-05-26T05:00:00-04:00">
    <meta itemprop="datePublished" content="2022-05-26T05:00:00-04:00">
    <meta itemprop="dateModified" content="2022-05-26T05:00:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Land%20Trust%20completes%20acquisition%20of%20Bell%20Station%20property&via=ithacatimes&url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ithaca.com/tncms/asset/editorial/73852778-dc33-11ec-b340-eb77090dbea5" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIthaca%20Times%20%5D%20Land%20Trust%20completes%20acquisition%20of%20Bell%20Station%20property&body=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"><div id="tncms-block-1923437" class="tncms-block"><div class="modal promo-designer-modal in centered  hidden tnt-dmp-reactive" id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true"  data-dmp-hide='["newslettersubscribers"]'>
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-1923437" class="block emphasis-h3   hidden tnt-dmp-reactive "  data-dmp-hide='["newslettersubscribers"]'><div class="clearfix">
    
    <div class="block-title title-1923437 ">
        <div class="block-title-inner">
            <h3>
                
                Title
                
            </h3>
        </div>
    </div></div><div class="promo-design"><div class="card-bg-color rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button>
            <div class="full-width-container">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg?resize=150%2C125 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg?resize=200%2C167 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg?resize=225%2C188 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg?resize=300%2C250 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg?resize=400%2C333 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg?resize=540%2C450 540w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/custom/image/6fb89c70-b401-11eb-88c0-47db9c4b83e1.jpg 640w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="625"
                height="521"
                alt="Title"
                ></div>
        
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                        <div class="lead-in dark ">
                            Ithaca Times Newsletter
                        </div>
                    
                    
                        <div class="headline large dark ">
                            Good morning Ithaca!
                        </div>
                    
                    
                        <p class="text dark ">
                            Get the the latest local news, weather & arts coverage from the Ithaca Times.
                        </p>
                    <div class="card email-signup">
                                <div class="alert alert-success" role="alert" style="display:none;">
                                    <p>
                                        <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
                                    </p>
                                </div>
                                <div class="alert alert-danger" role="alert" style="display:none;">
                                    <p>
                                        <strong>Error!</strong> There was an error processing your request.
                                    </p>
                                </div>
                                <div class="mailinglist-container dark  ">
                                        <form
                                            id="mailinglist-form-1923437"
                                            class="mailinglist-form form-validate"
                                            action="/tncms/mailinglist/signup/"
                                            method="post">
                                            <input type="hidden" name="submit" value="1">
                                            <div class="form-group mailing-lists ">
                                                
                                                    <div class="mailinglist-item priority-2 ">
                                                        
                                                            <input class="mailinglist-id-1923437" type="checkbox" name="list_id[]" value="7b030246-ffb8-11e8-9497-5b98eeea2753" data-name="Ithaca Times Daily" style="display:none;" checked>
                                                            <h4 class="mailinglist-title" style="display:none;">Ithaca Times Daily</h4>
                                                            
                                                        
                                                    </div>
                                                
                                                
                                            </div>
                                            <div class="form-group email-address">
                                                <div class="input-group">
                                                    <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                                                    <input id="email-1923437" class="form-control email" name="email" type="email" placeholder="Enter email address">
                                                </div>
                                                <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                                            </div>
                                            <div class="row">
                                                <div class="mailinglist-btn-container col-sm-6">
                                                    <button class="mailinglist-save btn btn-block btn-default">Subscribe<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                                                </div>
                                                
                                                    <div class="mailinglist-btn-container col-sm-6">
                                                        <a class="btn btn-default btn-block manage" href="https://www.ithaca.com/users/admin/mailinglist/">Manage my subscriptions</a>
                                                    </div>
                                                
                                            </div>
                                        </form>
                                    </div>
                                
                            </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-white"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-bb88be36-dc33-11ec-8b1a-0f121256da2e" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-bb88be36-dc33-11ec-8b1a-0f121256da2e" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1662">
            <meta itemprop="height" content="1247">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1396%2C1047">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1396%2C1047"><img
                        src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=400%2C300"
                        srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=150%2C113 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=200%2C150 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=225%2C169 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=300%2C225 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=400%2C300 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=540%2C405 540w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=640%2C480 640w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=750%2C563 750w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=990%2C743 990w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1035%2C777 1035w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1200%2C900 1200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1333%2C1000 1333w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1476%2C1107 1476w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?resize=1662%2C1247 2008w"
                        sizes="(min-width: 1396px) 881px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="1662"
                        height="1247"
                        alt="Senator Pam Helming – seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction – congratulated the land trust on acquiring the property on May 24."
                        class="img-responsive full tnt-restrict-img-bb88be36-dc33-11ec-8b1a-0f121256da2e white" />
            </div><style>
                .tnt-restrict-img-bb88be36-dc33-11ec-8b1a-0f121256da2e {
                    max-width: 1100px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p><em>Senator Pam Helming – seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction – congratulated the land trust on acquiring the property on May 24.</em></p><p><em> </em></p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">photo/Andrew Sullivan</span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="73852778-dc33-11ec-b340-eb77090dbea5">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Land%20Trust%20completes%20acquisition%20of%20Bell%20Station%20property&via=ithacatimes&url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ithaca.com/tncms/asset/editorial/73852778-dc33-11ec-b340-eb77090dbea5" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIthaca%20Times%20%5D%20Land%20Trust%20completes%20acquisition%20of%20Bell%20Station%20property&body=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-73852778-dc33-11ec-b340-eb77090dbea5-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="73852778-dc33-11ec-b340-eb77090dbea5" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="73852778-dc33-11ec-b340-eb77090dbea5" class="save-list-73852778-dc33-11ec-b340-eb77090dbea5-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="73852778-dc33-11ec-b340-eb77090dbea5" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>The Finger Lakes Land Trust (FLLT) today announced it has purchased the 480-acre Bell Station property, featuring 3,400 feet of pristine Cayuga Lake shoreline, from New York State Electric &amp; Gas (NYSEG). The property, located in the town of Lansing, Tompkins County, was the largest privately owned parcel of shoreline remaining in the Finger Lakes region.</p><p>Located on the eastern shore of Cayuga Lake, the Bell Station property features wooded hillsides overlooking the lake, extensive fields, and several small streams with cascading waterfalls. Acquisition of the site for conservation will greatly enhance public access to the east side of Cayuga Lake, which is 90% privately owned. Permanent conservation will also prevent residential development on the steep hillsides bordering the lake, helping to safeguard the lake’s water quality and prevent future harmful algal blooms.</p><p>For these reasons, the FLLT has been pursuing the conservation of the Bell Station property for a number of years. Its interest is shared by the state’s Department of Environmental Conservation (DEC), Governor Kathy Hochul, the Town of Lansing, Tompkins County, and other key stakeholders. Thanks to the efforts of Governor Hochul, concerned citizens, and other support, NYSEG agreed to cancel a public auction scheduled for October of 2021, and enter into a purchase agreement with the FLLT.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Funding for the purchase came from a $2 million dollar loan from the Park Foundation, $500,000 raised from individual donations, and an internal loan from the FLLT’s Opportunity Fund. The FLLT plans to sell the lakeshore portion of the property to the New York State Department of Environmental Conservation (DEC) to be managed for recreational uses including hiking, cross country skiing, wildlife watching, hunting, and fishing. In partnership with the Town of Lansing, the FLLT is also exploring the feasibility of utilizing 200 acres of the property for solar energy production.</p><p>The FLLT will formally open the Bell Station property to the public on an interim basis for low-impact recreation on Friday, June 10th. The public is invited to attend an open house from 2:00-4:00 p.m. Refreshments and guided hikes will be offered. Visit <a href="http://fllt.org/events">fllt.org/events</a> for directions and more info.</p><p>To learn about the FLLT&rsquo;s efforts to save Bell Station, including a short video, maps, and more, please visit <a href="http://fllt.org/savebellstation">fllt.org/savebellstation</a>.</p><p>“This is a tremendous win for the region and everyone who loves the Finger Lakes,” said Finger Lakes Land Trust Executive Director Andrew Zepp. “The Bell Station project will help maintain Cayuga Lake’s water quality while providing new opportunities for outdoor recreation and the generation of renewable energy. We are grateful to Governor Kathy Hochul and all of our elected officials and community members who acted together to make this possible.”</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-1543102" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543102" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543102');
                        
                });
            </script>
        </div>
    </div>
</div></div><p>Senator Pam Helming said, “Congratulations to the Finger Lakes Land Trust on completing the purchase of the Bell Station property and thank you to Andy Zepp and his team for their continued commitment to conserving the land and waters of the Finger Lakes. This was a phenomenal team effort by so many, including FLLT, the residents and Town of Lansing and Supervisor Ed LaVigne, Tompkins County, local watershed organizations, the DEC, and NYSEG. Together we achieved an important win for the region. With enhanced public access to Cayuga Lake for recreational purposes and added safeguards to protect water quality, the preservation of this land ensures the area will be enjoyed for generations to come.”</p><p>Assemblymember Anna Kelles said, “This is a huge win for our community. Congratulations to the Finger Lakes Land Trust and the coalition of local government officials, residents, the DEC, NYSEG, and Governor Hochul for working together to preserve this beautiful stretch of undeveloped land for future generations. I am thrilled that we were able to secure the preservation of 3,400 feet of pristine shoreline that is home to wooded hillsides, cascading waterfalls, critical bird habitat, and rare threatened plant species. Cayuga Lake is one of the last remaining fresh water reserves in the world. Preserving the forestlands will not only protect the lake from land erosion runoff and negative impacts of shoreline septic systems but will preserve the land for tourism and ecological education. I am especially grateful to Andy Zepp and his team at FLLT for their staunch commitment to preserve the natural environment and protect our ecosystems and habitats.”</p><p>Carl A. Taylor, President and CEO of NYSEG and RG&amp;E said, “NYSEG is pleased to officially transfer the Bell Station property to the Finger Lakes Land Trust. We applaud the efforts by all involved in ensuring the conservation and preservation of this incredible natural resource.”</p><p>Town of Lansing Supervisor Ed LaVigne said, “Congratulations to Andy Zepp and the staff at the Finger Lakes Land Trust for their hard work. The Town of Lansing is pleased with the purchase of this land. We look forward to continuing to work with the Land Trust and our local businesses to create positive results.”</p><p>By working cooperatively with landowners and local communities, the Finger Lakes Land Trust has protected over 28,000 acres of the region’s undeveloped lakeshore, rugged gorges, rolling forest, and scenic farmland. The FLLT owns and manages a network of over 45 nature preserves that are open to the public and holds perpetual conservation easements on 170 properties that remain in private ownership.</p><p>The FLLT focuses on protecting critical habitat for fish and wildlife, conserving lands that are important for water quality, connecting existing conservation lands, and keeping prime farmland in agriculture. The organization also provides programs to educate local governments, landowners, and residents about conservation and the region’s unique natural resources. </p><p>Information on the region&rsquo;s premier destinations for outdoor recreation may be found at <a href="http://www.gofingerlakes.org">www.gofingerlakes.org</a>, a resource created by the FLLT to encourage people to get outdoors. Additional information about the Finger Lakes Land Trust may be found at <a href="http://fllt.org">fllt.org</a>.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Land%20Trust%20completes%20acquisition%20of%20Bell%20Station%20property&via=ithacatimes&url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ithaca.com/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ithaca.com/tncms/asset/editorial/73852778-dc33-11ec-b340-eb77090dbea5" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIthaca%20Times%20%5D%20Land%20Trust%20completes%20acquisition%20of%20Bell%20Station%20property&body=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"73852778-dc33-11ec-b340-eb77090dbea5"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-73852778-dc33-11ec-b340-eb77090dbea5-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="73852778-dc33-11ec-b340-eb77090dbea5" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="73852778-dc33-11ec-b340-eb77090dbea5" class="save-list-73852778-dc33-11ec-b340-eb77090dbea5-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="73852778-dc33-11ec-b340-eb77090dbea5" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                    <a href="/search/?k=%22finger%20lakes%22#tncms-source=keyword" class="tag-finger-lakes label label-default" data-tncms-track-dmp='search: finger-lakes' rel="nofollow">Finger Lakes</a>
                </li> <li>
                    <a href="/search/?k=%22fllt%22#tncms-source=keyword" class="tag-fllt label label-default" data-tncms-track-dmp='search: fllt' rel="nofollow">Fllt</a>
                </li> <li>
                    <a href="/search/?k=%22cayuga%20lake%22#tncms-source=keyword" class="tag-cayuga-lake label label-default" data-tncms-track-dmp='search: cayuga-lake' rel="nofollow">Cayuga Lake</a>
                </li> <li>
                    <a href="/search/?k=%22ecology%22#tncms-source=keyword" class="tag-ecology label label-default" data-tncms-track-dmp='search: ecology' rel="nofollow">Ecology</a>
                </li> <li>
                    <a href="/search/?k=%22hydrography%22#tncms-source=keyword" class="tag-hydrography label label-default" data-tncms-track-dmp='search: hydrography' rel="nofollow">Hydrography</a>
                </li> <li>
                    <a href="/search/?k=%22economics%22#tncms-source=keyword" class="tag-economics label label-default" data-tncms-track-dmp='search: economics' rel="nofollow">Economics</a>
                </li> <li>
                    <a href="/search/?k=%22biology%22#tncms-source=keyword" class="tag-biology label label-default" data-tncms-track-dmp='search: biology' rel="nofollow">Biology</a>
                </li> <li>
                    <a href="/search/?k=%22land%20trust%22#tncms-source=keyword" class="tag-land-trust label label-default" data-tncms-track-dmp='search: land-trust' rel="nofollow">Land Trust</a>
                </li> <li>
                    <a href="/search/?k=%22bell%20station%20project%22#tncms-source=keyword" class="tag-bell-station-project label label-default" data-tncms-track-dmp='search: bell-station-project' rel="nofollow">Bell Station Project</a>
                </li> <li>
                    <a href="/search/?k=%22nyseg%22#tncms-source=keyword" class="tag-nyseg label label-default" data-tncms-track-dmp='search: nyseg' rel="nofollow">Nyseg</a>
                </li> <li>
                    <a href="/search/?k=%22habitat%22#tncms-source=keyword" class="tag-habitat label label-default" data-tncms-track-dmp='search: habitat' rel="nofollow">Habitat</a>
                </li> </ul>
                        </div>
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1814604" class="tncms-block"><section id="block-1814604" class="block emphasis-h4 dark  " ><div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        <div class="mailinglist-container">
                <form
                    id="mailinglist-form-1814604"
                    class="mailinglist-form form-validate"
                    action="/tncms/mailinglist/signup/"
                    method="post">
                    <input type="hidden" name="submit" value="1">
                    <div class="form-group mailing-lists ">
                        
                            <div class="mailinglist-item priority-2 ">
                                
                                    <input class="mailinglist-id-1814604" type="checkbox" name="list_id[]" value="7b030246-ffb8-11e8-9497-5b98eeea2753" data-name="Ithaca Times Daily" title="Ithaca Times Daily" style="display:none;" checked>
                                    <h4 class="mailinglist-title">Ithaca Times Daily</h4>
                                    
                                        <p><span>Your morning briefing with the top stories from the Ithaca Times. Includes: news, opinion, arts, sports and weather. Weekday mornings</span></p>
                                    
                                
                            </div>
                        
                    </div>

                    

                    <div class="form-group  email-address">
                        <div class="input-group">
                            <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                            <input id="email-1814604" class="form-control email" title="email" name="email" type="email" placeholder="Enter email address">
                        </div>
                        <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                    </div>
                    <div class="row">
                        <div class="mailinglist-btn-container col-sm-6">
                            <button class="mailinglist-save btn btn-primary btn-block">Get the Ithaca Times Daily!<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                        </div>
                        <div class="mailinglist-btn-container col-sm-6">
                            <a class="btn btn-default btn-block" href="https://www.ithaca.com/users/admin/mailinglist/">Manage subscriptions</a>
                        </div>
                    </div>
                </form>
            </div>
        
    </div></div>
        </div></div></section></div></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="73852778-dc33-11ec-b340-eb77090dbea5" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/news/lansing/land-trust-completes-acquisition-of-bell-station-property/article_73852778-dc33-11ec-b340-eb77090dbea5.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="73852778-dc33-11ec-b340-eb77090dbea5" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom asc realnames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.ithaca.com/users/login/?referer_url=https%3A%2F%2Fwww.ithaca.com%2Fnews%2Flansing%2Fland-trust-completes-acquisition-of-bell-station-property%2Farticle_73852778-dc33-11ec-b340-eb77090dbea5.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules">This is a space for civil feedback and conversation. A few
guidelines: 1. be kind and courteous. 2. no hate speech or
bullying. 3. no promotions or spam. If necessary, we will ban
members who do not abide by these standards.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"><div id="tncms-block-1657089" class="tncms-block"><section id="block-1657089" class="block emphasis-h3 light  " ><div class="clearfix">
    
    <div class="block-title title-1657089 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-1657089" class="card-grid-behavioral card-grid card-img- card-bg-color card-compact" ><div class=" row equal equal-wrap"><div id="tncms-recommendations-1657089" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-big-ad-top" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top');
                        googletag.pubads().refresh([gptAdSlots['fixed-big-ad-top']]);
                });
            </script>
        </div>
    </div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1239777" class="tncms-block"><section id="block-1239777" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1239777 ">
        <div class="block-title-inner">
            <h4>
                
                This Week's Issue
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-lg">
        
                
                <article id="card-summary-1239777-1686a142-dc50-11ec-abd4-7b4688b475bb" class="tnt-asset-type-link clearfix card summary has-image image-left inherit letterbox-style-white  tnt-section-cover-story-links">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-1686a142-dc50-11ec-abd4-7b4688b475bb media-preview link-asset " data-aspect="original"><figure class="photo layout-vertical letterbox-style-white">
            <div class="image" 
                >
                
                    <a href="https://issuu.com/ithacatimes/docs/full_3d34c3037ccd71" class="tnt-asset-link"  aria-label="May 25, 2022">
                
                
                
                <img
                    alt="May 25, 2022"
                    src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/1/68/1686a142-dc50-11ec-abd4-7b4688b475bb/628e675824792.preview.jpg?resize=175%2C200"
                    class="img-responsive  letterbox white"
                    loading="lazy"
                    width="1347"
                    height="1539" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://issuu.com/ithacatimes/docs/full_3d34c3037ccd71" class="tnt-asset-link" aria-label="May 25, 2022">
        

        
            May 25, 2022</a></h4></div>
    
                    
                    
                    
                    
                        
                        
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div><div id="tncms-block-1237885" class="tncms-block visible-lg visible-md"><section id="block-1237885" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1237885 ">
        <div class="block-title-inner">
            <h4>
                
                Trending Today
                
            </h4>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/ithaca/spongy-moth-caterpillars-behind-itchy-outbreak/article_d4ed9edc-dc51-11ec-a4a2-6b22e231140b.html" class="tnt-asset-link" aria-label="Spongy moth caterpillars behind itchy outbreak?">
        

        
            Spongy moth caterpillars behind itchy outbreak?</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/lansing/finger-lakes-land-trust-completes-purchase-of-bell-station-property/article_e17355ce-db9e-11ec-8647-2b4d111a6cce.html" class="tnt-asset-link" aria-label="Finger Lakes Land Trust completes purchase of Bell Station property">
        

        
            Finger Lakes Land Trust completes purchase of Bell Station property</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/opinion/letters_to_the_editor/a-letter-from-anjanette-brown-regarding-her-petition-against-the-superintendent-board-of-ed/article_91749570-72f3-11eb-b921-e70af77b61c3.html" class="tnt-asset-link" aria-label="A letter from Anjanette Brown regarding her petition against the superintendent, Board of Ed.">
        

        
            A letter from Anjanette Brown regarding her petition against the superintendent, Board of Ed.</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/ithaca/namgyal-monastery-institute-celebrates-groundbreaking-of-dalai-lama-s-library/article_30096600-cc32-11ec-adc6-d723d52b476d.html" class="tnt-asset-link" aria-label="Namgyal Monastery Institute celebrates groundbreaking of Dalai Lama’s library">
        

        
            Namgyal Monastery Institute celebrates groundbreaking of Dalai Lama’s library</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/ithaca/icsd-board-of-ed-certifies-election-results-amid-controversy/article_44e84de8-dbeb-11ec-bb78-7709f921ecd8.html" class="tnt-asset-link" aria-label="ICSD Board of Ed certifies election results amid controversy">
        

        
            ICSD Board of Ed certifies election results amid controversy</a></h5>
                    
                </li></ul>
    </div>
    
</section></div><div id="tncms-block-1969123" class="tncms-block"><div data-cswidget="10062"> </div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script><br></div><div id="tncms-block-1615347" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1615347" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1615347');
                        googletag.pubads().refresh([gptAdSlots['ad-1615347']]);
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1236397" class="tncms-block visible-lg visible-md"><section id="block-1236397" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236397 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1236397" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1236397" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1236397" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1236397" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1236397" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-decimal "><li><a href="/news/ithaca/update-missing-girl-found-safe/article_b161f958-d7b6-11ec-b227-7321999b76f4.html">UPDATE: Missing girl found safe</a></li><li><a href="/news/ithaca/cristine-donovan-to-take-over-as-racker-executive-director/article_e6547f2e-d7b0-11ec-9322-17b7d7ce32e1.html">Cristine Donovan to take over as Racker executive director</a></li><li><a href="/entertainment/music/downtown-ithaca-announces-2022-summer-concert-lineup/article_9de3179a-db17-11ec-a1ea-37844e974076.html">Downtown Ithaca announces 2022 Summer Concert lineup</a></li><li><a href="/news/ithaca/icsd-board-of-ed-certifies-election-results-amid-controversy/article_44e84de8-dbeb-11ec-bb78-7709f921ecd8.html">ICSD Board of Ed certifies election results amid controversy</a></li><li><a href="/news/lansing/finger-lakes-land-trust-completes-purchase-of-bell-station-property/article_e17355ce-db9e-11ec-8647-2b4d111a6cce.html">Finger Lakes Land Trust completes purchase of Bell Station property</a></li><li><a href="/entertainment/music/lindsey-buckinghams-latest-has-fleetwood-sounds/article_3152dae8-d59f-11ec-a6b9-a70e44b95507.html">Lindsey Buckingham's latest has Fleetwood sounds</a></li><li><a href="/news/ithaca/ithaca-college-commencement-is-this-weekend/article_0c9f9698-d7b9-11ec-887f-cf1fa6e532fb.html">Ithaca College commencement is this weekend</a></li><li><a href="/news/regional_news/interlaken-gives-vote-of-support-to-cayuga-nation/article_2107e512-d6c0-11ec-b579-37ab617f4f8f.html">Interlaken gives vote of support to Cayuga Nation</a></li><li><a href="/news/ithaca/grayhaven-motel-hosts-monthly-art-exhibits-currently-features-painter-rafael-lino/article_8cc6286c-d7ed-11ec-8657-cf02fb45cc82.html">Grayhaven Motel hosts monthly art exhibits, currently features painter Rafael Lino</a></li><li><a href="/opinion/columnists/surrounded_by_reality/the-time-machine/article_25166862-db17-11ec-a461-fb856cea8002.html">The Time Machine</a></li></ul></div>
        
        
            <div id="images-1236397" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-white">
            <div class="image" 
                >
                
                    <a href="/jamie-l-avery-jr-and-lisbeth-collado-of-west-palm-beach-fl-were-arrested-for/image_50ee8afa-d6c1-11ec-aa83-9b7611866959.html" class="tnt-asset-link"  aria-label="Jamie L. Avery, Jr., and Lisbeth Collado, of West Palm Beach, FL, were arrested for attempted murder after setting fires at a Tyre Love’s travel plaza while their one-year-old child was inside.">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Jamie L. Avery, Jr., and Lisbeth Collado, of West Palm Beach, FL, were arrested for attempted murder after setting fires at a Tyre Love’s travel plaza while their one-year-old child was inside."
                            class="img-responsive lazyload full white"
                            width="459"
                            height="459"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/5/0e/50ee8afa-d6c1-11ec-aa83-9b7611866959/62851638c6863.image.png?crop=459%2C459%2C382%2C1&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/5/0e/50ee8afa-d6c1-11ec-aa83-9b7611866959/62851638c6863.image.png?crop=459%2C459%2C382%2C1&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/5/0e/50ee8afa-d6c1-11ec-aa83-9b7611866959/62851638c6863.image.png?crop=459%2C459%2C382%2C1&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/5/0e/50ee8afa-d6c1-11ec-aa83-9b7611866959/62851638c6863.image.png?crop=459%2C459%2C382%2C1&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/5/0e/50ee8afa-d6c1-11ec-aa83-9b7611866959/62851638c6863.image.png?crop=459%2C459%2C382%2C1&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/5/0e/50ee8afa-d6c1-11ec-aa83-9b7611866959/62851638c6863.image.png?crop=459%2C459%2C382%2C1&resize=459%2C459&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-white">
            <div class="image" 
                >
                
                    <a href="/candor-citizens-of-the-year-bob-and-nancy-riggs-with-past-citizens-of-the-year/image_dc452946-dc30-11ec-87e9-cf02698403a1.html" class="tnt-asset-link"  aria-label="Candor Citizens of the Year Bob and Nancy Riggs with past Citizens of the Year in back. (Left to right): Nancy King, Roy Yarrington, Diane Craig, Hope VanScoy, Jeannie and Skip Jackson, and Lou and Sue Heavenrich.">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Candor Citizens of the Year Bob and Nancy Riggs with past Citizens of the Year in back. (Left to right): Nancy King, Roy Yarrington, Diane Craig, Hope VanScoy, Jeannie and Skip Jackson, and Lou and Sue Heavenrich."
                            class="img-responsive lazyload full white"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/d/c4/dc452946-dc30-11ec-87e9-cf02698403a1/628e3330a58a1.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-white">
            <div class="image" 
                >
                
                    <a href="/senator-pam-helming-seen-here-meeting-with-lansing-constituents-when-the-news-came-that-the/image_bb88be36-dc33-11ec-8b1a-0f121256da2e.html" class="tnt-asset-link"  aria-label="Senator Pam Helming – seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction – congratulated the land trust on acquiring the property on May 24.">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Senator Pam Helming – seen here meeting with Lansing constituents when the news came that the Bell Station property was put up for auction – congratulated the land trust on acquiring the property on May 24."
                            class="img-responsive lazyload full white"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/b/b8/bb88be36-dc33-11ec-8b1a-0f121256da2e/628e37f772b54.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-white">
            <div class="image" 
                >
                
                    <a href="/the-new-encore-players-community-theatre-venue-is-a-riding-arena-on-loch-ridge-farm/image_8f8cd6fe-dc34-11ec-b038-434e07f985d4.html" class="tnt-asset-link"  aria-label="The new Encore Players Community Theatre venue is a riding arena on Loch Ridge Farm which will be used for productions in warmer weather.">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="The new Encore Players Community Theatre venue is a riding arena on Loch Ridge Farm which will be used for productions in warmer weather."
                            class="img-responsive lazyload full white"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/ithaca.com/content/tncms/assets/v3/editorial/8/f8/8f8cd6fe-dc34-11ec-b038-434e07f985d4/628e3951a9c33.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1236397" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1236397" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-decimal "><li><a href="/news/ithaca/update-myrick-denies-wrong-doing-calls-accusations-disrespectful/article_b8ce40e8-c6a4-11ec-b301-6bcc123b4be2.html">UPDATE: Myrick denies wrong doing, calls accusations 'disrespectful'</a> (8)</li><li><a href="/news/ithaca/icsd-board-of-ed-certifies-election-results-amid-controversy/article_44e84de8-dbeb-11ec-bb78-7709f921ecd8.html">ICSD Board of Ed certifies election results amid controversy</a> (3)</li><li><a href="/news/dryden/borger-station-reports-decrease-in-emissions-from-2020-21/article_7cd5321e-c658-11ec-b3ca-db9714cd0bd6.html">Borger Station reports decrease in emissions from 2020-21</a> (3)</li><li><a href="/news/ithaca/ithaca-city-officials-propose-permanent-encampments-for-the-houseless/article_20381cf6-c5ea-11ec-b4d9-7b06fb4ebe0c.html">Ithaca city officials propose permanent encampments for the houseless</a> (2)</li><li><a href="/news/ithaca/county-ethics-board-will-investigate-myrick-reimagining-process/article_2500fe3a-d01a-11ec-9315-63d146e426db.html">County Ethics Board will investigate Myrick, ‘Reimagining’ process</a> (2)</li><li><a href="/opinion/columnists/surrounded_by_reality/the-time-machine/article_25166862-db17-11ec-a461-fb856cea8002.html">The Time Machine</a> (2)</li><li><a href="/news/ithaca/city-to-open-remagining-investigation-council-members-want-to-move-forward/article_251a2db8-d73d-11ec-a96e-c34fe181e09d.html">City to open 'Remagining' investigation, Council members want to move forward</a> (2)</li><li><a href="/opinion/columnists/community_connections/joe-talbut-and-green-space-we-all-can-enjoy/article_64dfa7e8-cf54-11ec-b21a-635912c6b0ba.html">Joe Talbut and green space we all can enjoy</a> (2)</li><li><a href="/news/ithaca/cafe-dewitt-prepares-to-open-under-new-ownership/article_7be3ae38-c6a0-11ec-9cfa-67b96d8ad112.html">Cafe DeWitt prepares to open under new ownership</a> (2)</li><li><a href="/news/ithaca/an-ethical-dilemma-accusations-of-unethical-behavior-slows-reimagining-process/article_8a356692-cc32-11ec-a28f-9f20878f3329.html">An ethical dilemma: Accusations of unethical behavior slows 'Reimagining' process</a> (2)</li><li><a href="/news/ithaca/two-students-going-head-to-head-for-ithacas-fourth-ward/article_b1899dd8-d1a7-11ec-b965-7b9c56843d00.html">Two students going head-to-head for Ithaca's fourth ward</a> (2)</li><li><a href="/news/ithaca/longtime-icsd-board-member-ainslie-out-budget-approved-in-school-vote/article_c6379e24-d65c-11ec-9026-cb8789127e78.html">Longtime ICSD board member Ainslie out, budget approved in school vote</a> (2)</li><li><a href="/news/regional_news/interlaken-gives-vote-of-support-to-cayuga-nation/article_2107e512-d6c0-11ec-b579-37ab617f4f8f.html">Interlaken gives vote of support to Cayuga Nation</a> (1)</li><li><a href="/opinion/guest_opinions/guest-opinion-addressing-the-mental-health-crisis-in-tompkins-county/article_2e6ed1ca-d661-11ec-b5a6-03955c2864a2.html">Guest Opinion: Addressing the Mental Health Crisis in Tompkins County</a> (1)</li><li><a href="/news/ithaca/namgyal-monastery-institute-celebrates-groundbreaking-of-dalai-lama-s-library/article_30096600-cc32-11ec-adc6-d723d52b476d.html">Namgyal Monastery Institute celebrates groundbreaking of Dalai Lama’s library</a> (1)</li><li><a href="/news/ithaca/salary-requirement-law-moves-on-to-common-council/article_3273a618-cb69-11ec-9814-ab53a6bc8b15.html">Salary requirement law moves on to Common Council</a> (1)</li><li><a href="/news/ithaca/icsd-budget-breakdown-what-to-know-before-the-may-17-vote/article_444aac02-d275-11ec-a4f3-57a71a4feb49.html">ICSD budget breakdown: What to know before the May 17 vote</a> (1)</li><li><a href="/opinion/guest_opinions/guest-opinion-are-the-kids-all-right/article_7097d4f2-c5ea-11ec-9032-ef835242fe00.html">Guest Opinion: Are the kids all right?</a> (1)</li><li><a href="/news/ithaca/rep-tom-reed-resigns-new-congressional-maps-proposed/article_7c245f22-d65f-11ec-b1f3-af81683dfddc.html">Rep. Tom Reed resigns, new Congressional maps proposed</a> (1)</li><li><a href="/opinion/columnists/surrounded_by_reality/oh-elon/article_a1916f20-d01a-11ec-862f-fb96b168f08b.html">Oh, Elon</a> (1)</li><li><a href="/news/ithaca/proposed-new-fire-station-on-ithacas-east-hill-would-be-all-electric/article_acd9d1c8-c5e9-11ec-92d5-af27077a00e6.html">Proposed new fire station on Ithaca's East Hill would be all electric</a> (1)</li><li><a href="/news/lansing/finger-lakes-land-trust-completes-purchase-of-bell-station-property/article_e17355ce-db9e-11ec-8647-2b4d111a6cce.html">Finger Lakes Land Trust completes purchase of Bell Station property</a> (1)</li></ul></div>
        
    </div>
</div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1656243" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1656243" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1656243');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1236374" class="tncms-block"><section id="block-1236374" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236374 ">
        <div class="block-title-inner">
            <h4>
                
                Online Poll
                
            </h4>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/opinion/question_of_the_week/have-you-gotten-your-first-sunburn-yet/poll_37319c08-dc50-11ec-b5e8-5f4ce33e50ad.html" class="tnt-asset-link" aria-label="Have you gotten your first sunburn yet?">
        

        
            Have you gotten your first sunburn yet?</a></h4>
            <div id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload"><div class="poll-image">
                        <div class="media-preview-37319c08-dc50-11ec-b5e8-5f4ce33e50ad media-preview poll-asset " data-aspect=""></div>
                    </div>
                <div id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-your-vote"></span>
                </div>
                <div id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-results" class="tnt-poll-results hide"></div>
                <div id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-container">
                    <form id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-form" class="tnt-poll-form" role="form" method="post" action="/opinion/question_of_the_week/have-you-gotten-your-first-sunburn-yet/poll_37319c08-dc50-11ec-b5e8-5f4ce33e50ad.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Sunburn? It'll be a tan by tomorrow" value="C9D622B8-ED60-0001-C1B91625DD291427"> Sunburn? It'll be a tan by tomorrow
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I'm an SPF wearing ADULT, thank you" value="C9D622BC-3500-0001-E8E415B0DD0B168C"> I'm an SPF wearing ADULT, thank you
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I plead the fifth" value="C9D622BE-CD80-0001-25BB1310B180D900"> I plead the fifth
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-back-vote" class="padding-top hide">
                <button id="poll-37319c08-dc50-11ec-b5e8-5f4ce33e50ad-1236374-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div><div id="tncms-block-1539360" class="tncms-block"><section id="block-1539360" class="block emphasis-h3   " ><div id="html-asset-1539360">
            <div class="html-content"><p class=MsoNormal><i><span style='color:#ACCBF9' align='center'>Like the Ithaca Times on Facebook!<span></i></p><iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Ftheithacatimes&width=152&layout=button_count&action=like&size=large&show_faces=true&share=true&height=46&appId=1704280666516212" width="152" height="46" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></div>
        </div></section></div><div id="tncms-block-1236366" class="tncms-block"></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1656244" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1656244" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1656244');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"><div id="tncms-block-1656248" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1656248" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1656248');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1236470" class="tncms-block"><section id="block-1236470" class="block emphasis-h4 dark  " ><div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        <div class="mailinglist-container">
                <form
                    id="mailinglist-form-1236470"
                    class="mailinglist-form form-validate"
                    action="/tncms/mailinglist/signup/"
                    method="post">
                    <input type="hidden" name="submit" value="1">
                    <div class="form-group mailing-lists ">
                        
                            <div class="mailinglist-item priority-2 checkbox">
                                <label>
                                    <input class="mailinglist-id-1236470" type="checkbox" name="list_id[]" value="7b030246-ffb8-11e8-9497-5b98eeea2753" data-name="Ithaca Times Daily" title="Ithaca Times Daily" >
                                    <h4 class="mailinglist-title">Ithaca Times Daily</h4>
                                    
                                        <p><span>Your morning briefing with the top stories from the Ithaca Times. Includes: news, opinion, arts, sports and weather. Weekday mornings</span></p>
                                    
                                </label>
                            </div>
                        
                            <div class="mailinglist-item priority-1 checkbox">
                                <label>
                                    <input class="mailinglist-id-1236470" type="checkbox" name="list_id[]" value="c089381a-dda2-11e6-81cc-2b0178661018" data-name="Weekend Planner" title="Weekend Planner" >
                                    <h4 class="mailinglist-title">Weekend Planner</h4>
                                    
                                        <p class="p1">Our top picks for weekend arts &amp; entertainment events delivered to your inbox every Thursday afternoon.&nbsp;</p>
                                    
                                </label>
                            </div>
                        
                            <div class="mailinglist-item priority-0 checkbox">
                                <label>
                                    <input class="mailinglist-id-1236470" type="checkbox" name="list_id[]" value="d4b96916-6576-11e7-a010-ffeda289ca59" data-name="Advertisers" title="Advertisers" >
                                    <h4 class="mailinglist-title">Advertisers</h4>
                                    
                                        <p>Marketing info for business owners and non-profit groups.</p>
                                    
                                </label>
                            </div>
                        
                    </div>

                    

                    <label class="warning-list hide has-error text-danger" for="list_id[]">You must select at least one email list.</label><div class="form-group  email-address">
                        <div class="input-group">
                            <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                            <input id="email-1236470" class="form-control email" title="email" name="email" type="email" placeholder="Enter email address">
                        </div>
                        <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                    </div>
                    <div class="row">
                        <div class="mailinglist-btn-container col-sm-6">
                            <button class="mailinglist-save btn btn-primary btn-block">Stay Tuned!<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                        </div>
                        <div class="mailinglist-btn-container col-sm-6">
                            <a class="btn btn-default btn-block" href="https://www.ithaca.com/users/admin/mailinglist/">Manage your lists</a>
                        </div>
                    </div>
                </form>
            </div>
        
    </div></div>
        </div></div></section></div></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div><div class="container-breakout"><div class="tnt-ads-container text-center hidden-xs " >
        <div id="fixed-leaderboard-bottom" class="tnt-ads dfp-ad" style="min-height:90px; min-width:728px;" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-bottom');
                        
                });
            </script>
        </div>
    </div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg " >
        <div id="fixed-leaderboard-bottom-mobile" class="tnt-ads dfp-ad" style="min-height:50px; min-width:320px;" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-leaderboard-bottom-mobile');
                        
                });
            </script>
        </div>
    </div></div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    

<div class="row">
    <div class="col-md-15 col-sm-3">
    <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1236382" class="tncms-block"><section id="block-1236382" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236382 ">
        <div class="block-title-inner">
            <h4>
                
                News
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li id="menu-ithaca">
                <a href="/news/ithaca/" >
                    
                    Ithaca
                </a></li><li id="menu-business">
                <a href="/news/business/" >
                    
                    Business
                </a></li><li id="menu-opinion">
                <a href="/opinion" >
                    
                    Opinion
                </a></li><li id="menu-opinion/editorials">
                <a href="/opinion/editorials" >
                    
                    Opinion/Editorials
                </a></li><li id="menu-sports">
                <a href="/sports" >
                    
                    Sports
                </a></li><li id="menu-columnists">
                <a href="/opinion/columnists/" >
                    
                    Columnists
                </a></li><li id="menu-photogalleries">
                <a href="/photos/" >
                    
                    Photo Galleries
                </a></li><li id="menu-videos">
                <a href="/video/" >
                    
                    Videos
                </a></li><li id="menu-articlearchives">
                <a href="/search" >
                    
                    Article Archives
                </a></li></ul></div>
        <div id="tncms-region-footer-col-one-under" class="tncms-region "></div>
    
    </div>
	<div class="col-md-15 col-sm-3">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1236384" class="tncms-block"><section id="block-1236384" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236384 ">
        <div class="block-title-inner">
            <h4>
                
                Arts &amp; Entertainment
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li id="menu-events">
                <a href="/calendar" >
                    
                    Events
                </a></li><li id="menu-dining">
                <a href="/dining/" >
                    
                    Dining 
                </a></li><li id="menu-music">
                <a href="/entertainment/music" >
                    
                    Music
                </a></li><li id="menu-art">
                <a href="/entertainment/art/" >
                    
                    Art
                </a></li><li id="menu-localbooks">
                <a href="/entertainment/books" >
                    
                    Local Books
                </a></li><li id="menu-living">
                <a href="/living" >
                    
                    Living
                </a></li><li id="menu-bestofithaca">
                <a href="/special_sections/best_of_ithaca" >
                    
                    Best of Ithaca
                </a></li><li id="menu-familymatters">
                <a href="/living/family_matters/" >
                    
                    Family Matters
                </a></li><li id="menu-health">
                <a href="/living/personal_health/" >
                    
                    Health
                </a></li><li id="menu-primetimes">
                <a href="/living/prime_times/" >
                    
                    Prime Times
                </a></li></ul></div>
        <div id="tncms-region-footer-col-two-under" class="tncms-region "></div>
    
    </div>
	<div class="col-md-15 col-sm-3">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1236510" class="tncms-block"><section id="block-1236510" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236510 ">
        <div class="block-title-inner">
            <h4>
                
                Guides
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li id="menu-wintertimes">
                <a href="/special_sections/winter_times/" >
                    
                    Winter Times
                </a></li><li id="menu-allaboutithaca">
                <a href="/special_sections/all_about_ithaca/" >
                    
                    All About Ithaca
                </a></li><li id="menu-summerithaca">
                <a href="/special_sections/summer_ithaca/" >
                    
                    Summer Ithaca
                </a></li><li id="menu-summercamps">
                <a href="/special_sections/summer_camp_guide/" >
                    
                    Summer Camps
                </a></li><li id="menu-studentsurvival">
                <a href="/special_sections/student_survival_guide/" >
                    
                    Student Survival
                </a></li><li id="menu-newcomers">
                <a href="/special_sections/newcomers_guide/" >
                    
                    Newcomers
                </a></li><li id="menu-fallguide">
                <a href="/special_sections/fall_guide/" >
                    
                    Fall Guide
                </a></li><li id="menu-readerswrites">
                <a href="/special_sections/readers_writes/" >
                    
                    Readers Writes
                </a></li></ul></div>
        <div id="tncms-region-footer-col-three-under" class="tncms-region "></div>
    
    </div>
	<div class="col-md-15 col-sm-3">
        <div id="tncms-region-footer-col-four" class="tncms-region "><div id="tncms-block-1236383" class="tncms-block"><section id="block-1236383" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236383 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-four-nav" class="tncms-region-nav"></div>
        <div id="tncms-region-footer-col-four-under" class="tncms-region "><div id="tncms-block-1269530" class="tncms-block"><ul id="footer-col-four-nav_menu" class="bullet-nav nav-list"><li><a href="/site/contact_us.html/">Contact Us</a></li>
<li><a href="/site/forms/news_tip">Submit News Tip</a></li>
<li><a href="https://portal.cityspark.com/add/event/IthacaTimes">Submit Calendar Event</a></li>
<li><a href="/site/advertise.html/">Advertise With Us</a></li>
<li><a href="/place_an_ad/">Place a Classified</a></li>
<li><a href="/site/forms/subscription_services/subscribe/subscribe">Subscribe to Print Paper</a></li>
<li><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001XWTM8Vlkw3bQ53p8HeQ8tBhETSaGpluHnqKj4Bb_cv_7nzZHsGLem5CguiD9SADoq3Ojf91CDDCFUNNM-nxuCj85rgMG5QHn3bX4pCBh--4%3D">Subscribe to Weekend Planner</a></li>
<li><a href="/site/forms/announcements/obituary/obit">Submit an Obituary</a></li>
<li><a href="/site/forms/letter_to_the_editor">Submit a Letter to the Editor</a></li>
<li><a href="/marketplace/">Local Business Directory</a></li>
<li><a href="/site/privacy.html">Privacy Policy</a></li>


</ul></div></div>
    
    </div>
	<div class="col-md-15 col-sm-3">
        <div id="tncms-region-footer-col-five" class="tncms-region "><div id="tncms-block-1236388" class="tncms-block"><section id="block-1236388" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236388 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Us
                
            </h4>
        </div>
    </div></div><address>
    <strong>Ithaca.com</strong><br>
    109 N Cayuga Street<br>
    Ithaca , NY 14850
    <br>
    
        <strong>Phone:</strong> (607) 277-7000<br>
        <strong>Email:</strong> <a href="mailto:production@ithacatimes.com">production@ithacatimes.com</a><br>
    
</address></section></div><div id="tncms-block-1236405" class="tncms-block padding-bottom"><div class="follow-links-1236405 default">
    
    <section id="block-1236405" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1236405 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/pages/The-Ithaca-Times/216472407397" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/TheIthacaTimes" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.ithaca.com",
  "sameAs" : ["https://www.facebook.com/pages/The-Ithaca-Times/216472407397","https://twitter.com/TheIthacaTimes"]
}
</script>
<div class="clearfix"></div></div></div>
        
        <div id="tncms-region-footer-col-five-under" class="tncms-region "></div>
    
    </div>
</div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1269507" class="tncms-block"><section id="block-1269507" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1269507 ">
        <div class="block-title-inner">
            <h4>
                
                Ithaca.com is powered by the following newspapers:
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-1269506" class="tncms-block"><ul id="footer-papers" class="list-inline text-center">
<li id="menu-ithacatimes">
                <a href="https://www.facebook.com/theithacatimes/" target="_blank">
                    
                    Ithaca<br>Times
                </a>
</li>
<li id="menu-trumansburgfreepress">
    <a href="https://www.facebook.com/theithacatimes/" target="_blank">
                    
                    Trumansburg<br>Free Press
    </a>
</li>
<li id="menu-interlakenreview">
    <a href="https://www.facebook.com/theithacatimes/" target="_blank">
                    
                    Interlaken<br>Review
    </a>
</li>
<li id="menu-ovidgazette">
    <a href="https://www.facebook.com/theithacatimes/" target="_blank">
                    
                    Ovid<br>Gazette
    </a>
</li>
<li id="menu-tompkinsindependent">
    <a href="https://www.facebook.com/theithacatimes/" target="_blank">
                    
                    Tompkins<br>Independent
    </a>
</li>
<li id="menu-thenewschronicle">
    <a href="https://www.facebook.com/theithacatimes/" target="_blank">
                    
                    The<br>News<br>Chronicle
    </a>
</li>



</ul></div><div id="tncms-block-1236389" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1236389"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">Ithaca Times </a>, 109 N Cayuga Street Ithaca , NY</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-1535479" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1535479" class="tnt-ads dfp-ad" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1535479');
                        googletag.pubads().refresh([gptAdSlots['ad-1535479']]);
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            <div id="blox-message-incompatible" class="notification wall alert alert-dismissable alert-warning hidden-print" data-message="blox ad blocker" style="display:none;">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <h4 class="clearfix meter-heading  media-heading row">
            Like the Ithaca Times?
        </h4>
        <p><strong>Please</strong> help support local journalism by whitelisting this site in your ad blocker. Thank you!</p>
    </div>
</template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("73852778-dc33-11ec-b340-eb77090dbea5")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc13233.add('act', dmpData);_cc13233.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news/lansing"],
            'tncms.asset.flags': ["featured"],
            'tncms.asset.keywords': ["finger lakes", "fllt", "cayuga lake", "ecology", "hydrography", "economics", "biology", "land trust", "bell station project", "nyseg", "habitat"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1236403'),
            query_input = d.getElementById('site-search-1236403-term'),
            search_dropdown = d.getElementById('site-search-1236403-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1236403 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1236401'),
            query_input = d.getElementById('site-search-1236401-term'),
            search_dropdown = d.getElementById('site-search-1236401-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1236401 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_1236420').click(function(e){
                                        $('#weather-1236420 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.fa820af8c4b7651b60faff4dca7ed722.js"></script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ window.addEventListener('DOMContentLoaded', function() {
                (function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=13233/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 13233 } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(__tnt.dmp.audienceExtracted);
            }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/dmp.reactive.0e53d3f9d235eed93a6018d451147284.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ function dmpAction(dmpData) {_cc13233.add('act', dmpData);_cc13233.bcp();} /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script>/*<![CDATA[*/ $('.mailing-lists input:checked').each(function(){
        var mailListData = 'is_maillist_subscriber: ' + $(this).val();_cc13233.add('act', mailListData);_cc13233.bcp();}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.136ae7f2f818eb47f6ccd0348c560674.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/ithaca.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc13233.add('act', dmpData);_cc13233.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>